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1 Introduction
Escenic Content Studio is the content creation, editing and management
application of the Escenic content management system. It is the system's
"front end", the most visible part of the system, and is intended to be used
on a daily basis by the writers and editors responsible for the content of an
Escenic-managed web site.
If you are reading this manual then you are probably an author, journalist or
editor who will be using Content Studio for one or more of the following tasks:
• Writing web content
• Editing web content
• Publishing web content (that is, making content actually visible on your web
site)
Vizrt has tried hard to make Content Studio as easy to use as possible, with
a modern, tabbed user interface, widespread use of drag-and-drop and lots
of keyboard shortcuts for experienced users. Nevertheless, it is probably
not a good idea to just start using it without knowing something about the
underlying system Content Studio depends on: the Escenic Content Engine.
If you spend half an hour now reading this chapter, you should find Content
Studio a lot easier to understand.

1.1

The Escenic Content Engine
The Escenic Content Engine is a system for managing and maintaining large
web sites such as newspaper web sites. The Escenic name for such a web site
is publication. When you see the word "publication" in this manual, it means
"web site managed by the Escenic Content Engine".
All access to the content of an Escenic publication is managed by the Escenic
Content Engine, which does not run on your computer, but on a server in the
network. Most of the content is stored by the Content Engine in a database
system, which also runs on a server in the network. This means that:
• You cannot use Content Studio unless your computer is connected to the
network.
• When you work with Content Studio, nothing important is stored on your
computer.

1.2

The Escenic Publication Model
The Content Engine has its own idea of how a web site or publication is
structured, called the publication model. All Escenic publications are based
on this publication model and therefore have the same basic structure, which
is reflected in Content Studio.
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An Escenic publication is made up of content and sections. Content is the
actual information that makes up your publication: news articles, images,
multimedia objects (audio and video files) and so on. The individual articles,
images and so on are collectively referred to as content items. Sections are
the subdivisions of the publication in which the articles appear and correspond
approximately to the sections of a print newspaper or magazine. The menu
system displayed in an Escenic publication is usually based directly on the
publication's section structure.
A publication must have one top section that corresponds to the whole
publication, and each section may contain 0 or more subsections. The sections
therefore form a tree structure like the folders in a computer file system.
A content item can belong to one and only one section, which is called its
home section. However, a content item may appear in many sections. A
news article concerning a football transfer, for example, might belong to the
sports section of a newspaper, but appear in both the sports and business
sections. A content item's home section determines its published appearance:
this article will look like a sports article even for users who arrive from the
newspaper's business section.
A section has one or more section pages which contain links to some of
the content items in the section. One of these section pages is the section's
active page, and is displayed whenever a reader of the publication clicks
on a link to the section. The active page is, in other words, a kind of "front
page" for the section. Although a section may have many section pages,
only one of them can be active at any particular time. This enables editors
to have alternative section pages ready for activation and switch between
them instantaneously. It can be a useful means of preparing for alternative
outcomes to upcoming events such as elections and sporting competitions.
The links on a section page are called teasers. A teaser is a summary,
and usually rather more than a link. A typical teaser might consist of an
article headline, some summary text describing the content of the article, a
thumbnail image and a "read more.." link. A publication will normally have a
number of different teaser types ("large", "medium" and "small", for example).
The teasers are laid out on a section page in a grid layout. A grid layout is a
set rectangular areas, each of which has a predefined location and size and
can contain a predefined number of teasers. The areas in a grid layout have
names which usually describe their location on the page or their intended
content ("top stories", "left" "center" and "right", for example).
Teasers can be organized in groups. Teaser groups can then be placed in
areas in the same way as single teasers.
Content items can be interrelated in various ways. An image or video clip, for
example, can be made to appear in a news article by relating it to the article.
Lists of "related article" links can be generated in the same way.

Page 8

Copyright © 2008-2011 Vizrt

Escenic Content Studio User Guide

1.2.1

Your Publication
Escenic publications can be very different from one another, in order to meet
the particular requirements of different publishers, audiences and subject
matter. Each publication has its own particular structure and types of content
that have been defined by the publisher's designers and programmers, often
with assistance from Escenic consultants. The following things are publicationspecific:
sections
Each publication has its own section structure.
content types
A content item is composed of fields, and different content item types
have different fields. A news article content item, for example, might
consist of the fields "headline", "teaser-text" and "body" (the main
story), while a "review" content item might have the fields "headline",
"body", "subject" "verdict" and "rating". Each publication defines its own
article types along with rules specifying the sections in which they can
be used.
relation types
All relations between content items have a type which determines the
purpose of the relation. An image that is linked to a news article using
a "thumbnail" relation, for example, might be displayed as a thumbnail
image in summaries for the article, while an image that is linked using
a "top" relation might be displayed at the top of the article itself. Each
publication defines its own relation types and their meaning (i.e, what
they are used for).
layout types
Grid layout types determine the possible content of section pages - how
many areas the page contains, how many summaries of what type each
group can contain and so on. Each publication defines its grid layout
types and also defines which grid layout types can be used in each
section.
summary types
A summary type defines the content item fields from which a content
summary is composed. Summaries are used for teasers, relations, in
lists, search results etc.
Because all publications are different, so are many aspects of Content
Studio. The examples and screenshots you see in this manual will often
not exactly match what you see on your screen, because they are based
on Vizrt's internal test and demo publications, not your publication.
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1.3

Content And Layout
If you have previously mostly worked with a print document editor such as
Microsoft Word or even an HTML editor like FrontPage or Dreamweaver, then
one of the first things you will notice when you start Content Studio is that
there is no Format menu. Content Studio is a pure content editor. It allows
you to create, modify and publish content, but provides almost no direct
control over the final appearance of the content.
This is a deliberate choice, based on the belief that the layout of web pages is
the responsibility of web designers, not writers. For the same reason, Content
Studio provides you with a very simple editing environment in which you can
concentrate on content, and is definitely not a "What You See Is What You
Get" (WYSYIWYG) editor. A preview function lets you see the article as it will
appear when published, but you cannot write in this view (previews are in fact
displayed in your browser). The preview function can sometimes be useful
to get an impression of what your finished article will look like. You might,
for example, want to know whether a heading you have written is "too long"
or not. It's worth remembering, though, that the web is not like a printed
newspaper or magazine and you cannot guarantee what your readers will
actually see. Someone using a different browser, a computer with a smaller
screen or perhaps a mobile phone will not see what you see.
Your publication designers may grant you some indirect control over certain
aspects of the final layout. You might, for example, be able to choose the
summary type used to display a particular article on a section page. In other
cases, however, the publication may not allow such choices. You may also
have some control over minor aspects of layout when editing articles: you
will probably have options for highlighting text (bold/italic/underline) and
creating lists of various types. You may also be able to insert headings within
your articles. Exactly what those headings will look like on the published web
pages, however, is outside your control.

1.4

Web Publication Characteristics
A web site, unlike a print publication, does not have a fixed number of pages,
and disk storage is so cheap that there is no practical limit to content. An
Escenic publication, like most large, active web sites will therefore usually
have far more content than is immediately visible, like an iceberg that
is mostly hidden below the surface of the water. If you are used to web
publishing then this is probably obvious; if you come from a print publishing
background then it may not be. It is useful to keep this aspect of web
publishing in mind when learning to use Content Studio.
Nothing you add to the publication using Content Studio is ever deleted.
Content Studio has a kind of delete function, but all it does is mark a content
item as deleted, so that it will no longer be returned by searches. It is still
there, and can be restored at any time. Normally, however, articles are not
deleted, with the result that the publication grows in size year by year. In this
sense, a web publication is like a print publication plus its archives. What
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readers see on the section pages of the publication corresponds approximately
to the "current issue" of a paper publication, but all the articles they can't see
there are still accessible in a variety of ways:
• Through links to related articles
• Through the publication's search function
• Through external search engines such as Google
When you work with the section pages in Content Studio, all you are doing is
determining how much exposure various articles will get. If you remove an
article summary from a section page, you haven't deleted the article from the
publication, just made it harder for readers to find.
The other aspect of this is that you have access to the whole publication when
working in Content Studio. When writing an article on a particular subject you
can use Content Studio's search function to find all previous articles on the
same subject and make use of them: read them as background, copy text from
them or include links to them in your article.

1.5

Workflow, Permissions and Locking
The maintenance of a large, dynamic website is a collective endeavor
involving many people with different skills and responsibilities. Therefore most
web site publishers have internal routines and procedures that formalize this
division of labor. The Escenic Content Engine can be configured to reflect the
varying internal procedures used by different website publishers.
In order to use Content Studio to work on a publication, you must have been
registered as a user by the publication's administrator and given a login user
name and password. When the administrator registers you as a user, he will
assign you to group which has an associated set of rights. You might, for
example, be assigned to the group "Sports Journalist", which gives you the
right to do lots of things in the sports section of the publication, but rather
more limited access elsewhere.
Permissions
The Content Engine's permissions system is very flexible, and is configured
in very different ways by different publishers, with completely different roles
and permissions that reflect their internal organization and corporate culture.
However, as a Content Studio user you will most probably have been assigned
to a group that is not allowed to do everything. That means that some of the
contents of this manual may not apply to you.
It is probably a good idea to find out what permissions you have before
you read any further or start using Content Studio, so that you don't
waste time learning about things that are not relevant for you, or
wondering why a particular function always seems to be disabled.
Locking
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When many people work together on a publication, conflicts where two
or more people need to work on the same content at the same time will
inevitably arise. The Content Engine resolves such conflicts by means of a
locking system, whereby the first person to start modifying some content
"locks" it so that other people cannot modify it until they have finished. These
locks are not applied to whole content items, but to the individual fields of
which a content item is composed. This means, for example, that it is possible
for an editor to add images to a news article while a journalist is still working
on the article's body text. Section pages are also locked in the same way. In
this case, a change to any part of a section page locks the whole page.

1.6

System Requirements
In order to run Content Studio you need a Windows-compatible PC or Apple
Mac with the hardware and software listed in the following sections.

1.6.1

Hardware
Content Studio requires the following minimum hardware configuration:
• 1024*768 display resolution (higher recommended)
• 1GB RAM (2GB recommended)
• 1.6GHz single-core processor (2GHz recommended)

1.6.2

Software
Content Studio is supported for use on computers running the following
operating systems/Java run-time environments:
• Microsoft Windows XP with Sun Java 6
• Microsoft Windows Vista with Sun Java 6
• Microsoft Windows 7 with Sun Java 6
• Mac OS X 10.5 (Leopard) with Apple Java 6
• Mac OS X 10.6 (Snow Leopard) with Apple Java 6
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2 Using Content Studio
Content Studio is a Java WebStart application. That means you do not need
to install it on your computer in the usual way - you just visit a web site with
your browser and click on a link there. Clicking on the link downloads and
installs the application to your computer, starts the application and leaves
behind an icon on your desktop which you can use to start the application in
future. You will notice that subsequently the application starts more quickly
because it is already downloaded.
Occasionally a new version of the application may be installed on your
company's servers. The new version will then be automatically downloaded to
your computer the next time you start the application.
In order to start using Content Studio you need the following items from your
publication/system administrator:
• The URL of the web page containing the WebStart link for Content Studio.
• A user name and password for the publication you are going to work on.
Content Studio will often let you do the same thing in many different
ways: selecting menu options, pressing keyboard shortcuts, clicking on
buttons or "dragging and dropping". This User Guide does not attempt
to describe every possible method. The menu option method is usually
described for most operations. The keyboard alternatives for all menu
options are displayed on the menu items themselves, so you can quickly
find out how to perform the operation using the keyboard.
Many operations can be carried out by dragging and dropping, and this
method is often described in the User Guide. The best way to find out all
the things you can do in this way, however, is trial and error.
Buttons that have icons rather than text labels can sometimes be
ambiguous, so they are described here. However, it's often enough to
hold your mouse pointer over the button for a few seconds: a short text
describing the button's purpose is then displayed.

2.1

Starting and Ending Work Sessions

2.1.1

Starting
To start a Content Studio session:
1.

If you are starting Content Studio for the first time, start your browser
and navigate to the URL given to you by your publication/system
administrator and click on the Content Studio link or button you see there.

Copyright © 2008-2011 Vizrt

Page 13

Escenic Content Studio User Guide

If you have already used it before, click on the Content Studio icon on
your desktop.
You might see a warning, asking if you want to trust Escenic AS and run
Escenic Content Studio. The easiest way to get rid of this warning, is to
check "Always trust content from this publisher" and press "Run". If you
have additional plug-ins installed, you might have to accept each plug-in
individually.

2.

2.1.2

Type your user name and password and press Enter.

Ending
To end a Content Studio session, select File > Exit.
Content Studio remembers what you were doing between work sessions.
The next time you start the application, all the items that were open when
you finished will still be there, the same tabs will be visible and so on.

2.2

The Application Window
The Content Studio window is divided into the following main areas:
• The menu bar at the top of the window.
• A navigation area on the left, containing three panels, Search, Sections,
and Clipboard.
• A work area on the right that is empty the first time you start Content
Studio, but will be used to display the content items and sections you open.
• The live panel at the bottom of window. This panel is hidden by default.
You can display it by selecting View > 5 Show boxes or by clicking on the
expand button

2.2.1

at the center-bottom of the window.

The Menu Bar
The menu bar contains five menus: File, Edit, View, Tools and Help.

2.2.1.1

The File Menu
The File menu contains the following options:
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New
Creates a new item. A sub menu is displayed from which you can select
the type of item you want to create.
Upload local file(s)...
Uploads one or more files from your computer to the Content Engine on
the server. An Open File dialog is displayed, which you can use to find
the file you want to upload.
Open selected
Opens the currently selected item in an appropriate editor.
Close editor
Closes the active editor.
Save
Saves any changes you have made in the active editor.
Save as...
Saves any changes you have made in the active editor under a new
name. Enter the new name in the displayed dialog.
Duplicate active editor
Copies the content in the active editor, and opens a new editor with the
same content.
Delete
Deletes the currently selected item.
Rename
Lets you rename the currently selected item.
Refresh
Refreshes the contents of the Content Studio window. It may occasionally
be necessary to use this to ensure that you are viewing the most recent
version of an article rather than a locally-cached copy.
Sign out and restart
Signs you out from the Content Engine without stopping Content Studio,
and displays the login window so that you can log in again. This function
is useful if you have more than one login and switch between them
frequently, as it is much faster than stopping and restarting Content
Engine.
Log out and exit
Logs you out and terminates Content Studio. The next time you start
Content Studio you will be asked for a user name and password, even if
you checked Log me in automatically on this machine in the login
window.
Exit
Terminates Content Studio.
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2.2.1.2

The Edit Menu
The Edit menu contains the following options:
Undo
Reverses the last change you made.
Redo
Redoes a change you just reversed with Undo.
Cut
Cuts the selected item and stores it ready for pasting. This could be
some selected text in an editor, but it could also be a whole content
item.
Copy
Copies the selected item ready for pasting. This could be some selected
text in an editor, but it could also be a whole content item.
Paste
Pastes a previously cut or copied item to the currently selected location.
This option is only enabled if:
• The system clipboard contains something to paste.
• The system clipboard contents are suitable for pasting into the
currently selected location.
Remove/Delete selected item
Removes or deletes the selected item. The text of this menu item varies
according to the item selected. Delete selected item means that
the selected item will be completely deleted. Remove means that the
selected item will only be removed from the current context: it will still
be present in the publication.

2.2.1.3

The View Menu
The View menu contains the following options:
Reload
Reloads all content. It may occasionally be necessary to use this function
to correct display errors.
1 Search
Displays/hides the Search panel in the navigation area. See section
2.2.2.1 for further information.
2 Sections
Displays/hides the Sections panel in the navigation area. See section
2.2.2.2 for further information.
3 Clipboard
Displays/hides the Clipboard panel in the navigation area. See section
2.2.2.4 for further information.
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5 Show boxes
Displays/hides the live panel at the bottom of the screen. See section
2.2.4 for further information.
6 Show relations
Displays/hides the relations area in content editors. See section 5.2.2
for further information.
Resize section editor
Reduces the width of the section content area in a section page editor to
50% of the available width, leaving the other 50% for displaying teaser
content.
Hide all panels/Restore panels
Displays/Hides both the navigation panels on the left of the window and
the live panel at the bottom of the window.
Configure panels...
Displays the Configure panels dialog. See section 2.2.4.1 for further
information.
View keyboard shortcuts...
Displays a dialog containing a list of all keyboard shortcuts.
2.2.1.4

The Tools Menu
The Tools menu contains the following options:
Enable spell checking
Enables/disables spell checking.
Spell checker language
Displays a sub-menu from which you can select the required language.

2.2.1.5

The Help Menu
The Help menu contains the following options:
Help
Displays help on using Content Studio.
About
Displays version, copyright and legal information about Content Studio.

2.2.2

The Navigation Area
The navigation area contains four panels you can use to find and keep track
of the sections and articles you want to work with. You can switch between
the panels by clicking on the vertical tabs lined up down the left side of the
window.
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2.2.2.1

Search Panel
You can use the Search panel to search the publication for content. It
searches the entire publication database. At the very top of the panel is a
search tool bar. Below that is the search specification area, and below
that the results area used for displaying search results.
Search t oolbar

Search specificat ion area

Result s area

To search for articles:
1.

Enter your search criteria in the search specification area.

2.

Press Enter or click on the Search button in the tool bar.

Search Specification Area
Use the controls in the search specification area as follows:
Find
Enter words you think will appear in the content items you are interested
in. The search function will list all content items that contain all of
the words you enter. Entering Barack Obama, for example, will find all
articles containing both "Barack" and "Obama" (even if the words do not
appear together). It will not, however return articles that only contain
"Barack" or only contain "Obama".
You can search for any words in any content items fields and/or
properties: you can enter an author's name, for example, in order to
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search for content items created by a particular person, or if you know
the ID of the content item you are looking for, you can enter that.
You can search for images, video clips and other multimedia objects by
entering words or strings of characters that you think may appear in
the metadata stored with the object: the name of the file, for example.
Metadata is "data about data", and exactly what metadata is stored
with the multimedia objects in your system depends on how the system
has been set up. Typical items of metadata that might be stored with
an image include the name of the image file, its resolution, the date on
which it was taken, the name of the photographer, technical details such
as the focus and aperture settings used, comments and so on.
You can use the * character as a wild card in your search terms.
Date
You can restrict your search to content published during a particular
period by entering a date specification in this field.
A date specification consists of a date, a duration or a date followed
by a duration. Content Studio accepts dates in a wide range of formats.
A duration is a number preceded by a plus or minus sign: -n means
a period of n days prior to a date and +n means a period of n days
following a date. If you specify a duration on its own, then the date in
question is today's date; otherwise the date you specify is used. If you
specify both a date and a duration, then you must specify the date first
and leave a space between the date and the duration.
Here are some example date specifications:
• 05 or 5 - the 5th of this month.

• 0510 or 510 - in Europe, October 5th this year; in the US, May 10th
this year
• 05102007 - in Europe, October 5th 2007; in the US, May 10th 2007
• -31 - today and the preceding 30 days
• +7 - today and the following 6 days

• -5h - from 19:00 this evening until midnight

• +5h - from midnight last night until 05:00 this morning

• 0510 -31 - October 5th/May 10th this year and the preceding 30 days
• 0510 +7 - October 5th/May 10th this year and the following 6 days
You can include a variety of punctuation marks in dates: 05102007,
05.10.2007, 05/10/2007 and 05-10/2007 will all be accepted and
interpreted as the same date.
If you leave the field empty, then the whole publication history is
searched.
Advanced
Displays further controls that you can use to "fine tune" your search:
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States
You can use this field to restrict your search to content items that
are in a particular state: only published documents, for example.
Select the state you are interested in. Hold down the Ctrl key and
click again to deselect it.
Sections
You can use this field to restrict your search to content items that
appear in a particular section of the publication. Select the section
you are interested in. Hold down the Ctrl key and click again to
deselect it.
Search in all dates
If you have specified something in the Date field, then usually only
articles published in the specified period will be returned. If you
check this option, however, then all dates stored with an article
are used, and you will also get articles that changed in other ways
during the specified period (articles that were created, activated,
expired or last modified during the period, for example).
At the bottom of the search specification area are the following buttons: you
can use them to limit the types of content items returned by the search:
All
The search will return all kinds of content items.
Articles
The search will return content items with mainly textual content.
Images
The search will return content items containing images.
Video
The search will return content items containing video clips.
Attachments
The search will return content items containing multimedia attachments
such as video, sound, documents (PDFs, for example).
Other
The search will return content items with content that does not fall into
any of the other categories (personal profiles, for example).
Results Area
The results of your search are listed in this area. If many articles are found,
you can use the scroll bar on the right of the list to view the whole list. If more
than 1000 articles are found, only the first 1000 are listed: the approximate
number found is displayed at the bottom of the list.
You can change the layout of the results list by clicking on the View button
above the list. Click on the main part of the button to cycle through the
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different layouts, or click on the button's menu icon to select the layout you
want from a list.
Tool Bar
The Search tool bar contains the following tools:

Show previous search.

Show next search.

Reset all search specifications to their default values, and execute a new
search.

Execute a new search. Note that the search is automatically executed
whenever you press enter, or change a search specification.
2.2.2.2

Sections Panel
The Sections panel gives you access to the sections of a publication and to
the components of each section (inboxes, section pages and lists).
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At the top of the Sections panel is the section tree view. This contains all
the sections of the publication in an expandable tree view. Below this are the
section component tabs: Inboxes, Pages and Lists.
Sect ion t ree view

Sect ion com ponent t abs

To select a section, click on its name in the section tree view. To display that
section's section pages, click on Pages. To display its lists, click on Lists. To
display its inboxes, click on Inboxes.
To open a section for editing, right-click on it and select Open Section from
the displayed menu. For information about editing sections, see chapter 3.
Section Pages Tab
This tab lists all the section pages for the currently selected section. The
section page at the top of the list is the active page (the one that is actually
displayed in the publication at present).
To open a section page for editing, double-click on it, or select it and press
Enter. The section page will then be displayed in an editor tab in the work
area. For information about editing section pages, see chapter 4.
To rename a section page, open it for editing (see above), modify the Name
field and save your changes.
To create a new section page:
1.
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Right-click anywhere in the section pages list.
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2.
3.

Select Create New Section Page... from the displayed menu.
Enter a name for the new section page and click OK in the displayed
dialog.

To set the active section page, open the section page you want to activate
(see above) and click on the section page editor's Publish button.
To delete a section page, select it and then select Edit > Delete selected
item or press Delete.
Lists Tab
This tab contains the names of all the lists in the currently selected section.
A list is an ordered list of content items that are related in some way (a list
of articles related to an ongoing news issue, for example). They can be used
to create a collection of summaries that can be appear in several locations
but be maintained in one place. You can, for example set up a section page in
which item 1 from a particular list appears in one location, item 1 and 2 in a
second location and items 1 to 5 in a third location. You can then subsequently
update all these locations in a single operation by replacing list item 1 with a
new story.
To open a list for editing, double-click on it, or select it and press Enter. The
list will then be displayed in an editor tab in the work area. For information
about editing lists, see chapter 6.
To rename a list, open it for editing (see above), modify the Name field and
save your changes.
To create a new list:
1.
2.
3.

Right-click anywhere in the list of lists.
Select Create New List... from the displayed menu.
Enter a name for the new list and click OK in the displayed dialog.

To delete a list, select it and then select Edit > Delete selected item or
press Delete.
Inboxes Tab
This tab contains the names of all the inboxes in the currently selected
section. For more information about inboxes, see section 2.2.2.3.
To delete an inbox, select it and then select File > Delete from the displayed
menu.
To rename an inbox, select it, select File > Rename and enter a new name.
To create a new inbox:
1.
2.
3.

Right-click anywhere in the inbox list.
Select Create New Inbox... from the displayed menu.
Enter a name for the new inbox and click OK in the displayed dialog.
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You cannot delete or rename the default inbox Inbox.

2.2.2.3

Inboxes Panel
An inbox is a list of content items. Each section of a publication can have
any number of inboxes, which can be used for any purpose. An inbox always
belongs to a single section. A content item can be moved between inboxes,
but cannot appear in two inboxes simultaneously.
Inboxes are generally used by section editors to organize publication work
flow. The editor might, for example, create an inbox for each person that
works on the section, and then assign jobs by adding content items to the
inboxes. Another editor might create inboxes that represent different stages in
a workflow, so that journalists can move content items between the inboxes as
a means of marking progress.
Most of the Inboxes panel is taken up by a display area for the currently
selected inbox. Above this is a pull-down list for switching between the
inboxes in the section and a View button for changing the layout of the inbox
display. Below the display area are push buttons that you can also use to
switch between the inboxes in the section. The currently selected button is
highlighted.

The View button lets you switch between three different views of the content
items in the inbox: Detail, List and Thumbnail. In the Detail and List views
there are column heading buttons at the top of the inbox that you can use to
sort the content items in various ways: clicking on Title, for example, sorts
the content items by their titles, and clicking a second time reverses the sort
order.
To edit one of the content items in an inbox, either double-click on it, or select
it and press Enter. It will then open in an editor in the work area.
To move content items between inboxes:
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1.

Select the content items you want to move.

2.

Drag them down to the push buttons at the bottom of the inbox and hold
them over the button for the inbox you want to move them to. After a
moment or two, the new inbox will open.

3.

Drag the content items up into the new inbox and drop them.
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2.2.2.4

Clipboard Panel
The clipboard is your personal content list. You can use it to hold content items
you are working on or want to use for reference. Clipboard contents are saved
between sessions: any items you leave on the clipboard when you log out from
the Content Studio will still be there the next time you log in.

The clipboard looks very similar to an inbox, and works in the same way. The
View button lets you switch between three different views of the content
items in the clipboard: Detail, List and Thumbnail. In the Detail and List
views there are column heading buttons at the top of the clipboard that you
can use to sort the items in various ways: clicking on Title, for example, sorts
the items by their titles, and clicking a second time reverses the sort order.
To edit one of the items on the clipboard, either double-click on it, or select it
and press Enter. It will then open in an editor in the work area.

2.2.3

The Work Area
When you open an item to work on it, it is displayed in the work area in a
tabbed panel called an editor. Each item you open is displayed in its own
custom editor: the controls in an editor vary according to the type of item it
contains. If you open more than one item, then the editors are stacked on top
of each other in the work area.
Each editor has a tab at the bottom, and you can:
• Switch between editors by clicking on the tabs.
• Close editors by clicking on the tab close buttons (

).

There are four different types of editors:
• Section editors (see chapter 3)
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• Section page editors (see chapter 4)
• Content editors (see chapter 5)
• List editors (see chapter 6)

2.2.4

The Live Panel
The live panel is a panel at the bottom of the Content Studio window that
can be used to hold boxes. The live panel is hidden the first time you start
Content Studio. You can display it by selecting View > 5 Show boxes or by
clicking on the expand button (

) at the center-bottom of the window.

Boxes are small plug-in applications that can be created by third parties to add
functionality to Content Studio:

Three general-purpose plug-ins are delivered as a standard part of Content
Studio:
RSS Feed
An RSS feed panel is a box containing links delivered via RSS. You
can add any number of RSS feed panels to your live panel area, each
displaying regularly updated links from a different RSS feed. Clicking one
one of the links will open it in your browser.
Search
A search panel is a box containing the results of an Escenic search - it's
rather like a mini version of the Search panel. You can add any number
of search panels to your live panel area, each displaying the results of
a different search. The search results can be selected and dragged in
exactly the same way as ordinary Search panel results.
Related Content Finder
The related content finder searches for content that is similar to the
current content item - that is, content that appears to be about the same
subject. You can use it as a research tool to find more information related
to an article you are working on, or to turn up a set of candidate articles
for linking to. You can set up a related content finder box to search using
either Escenic Related Search (which searches your Escenic database) or
Google News Search (which searches news articles on the web). You can,
of course, add two related content finders to your live panel area, one
set up to search internally and the other set up to search the web.
All boxes have a refresh button at the right end of their title bars:

Page 26

Copyright © 2008-2011 Vizrt

Escenic Content Studio User Guide

Clicking on this button refreshes the content of the box (refreshes
the feed/repeats the search in the case of the standard boxes). Note,
however, that you can configure boxes to refresh automatically at
specified intervals (see section 2.2.4.1.
2.2.4.1

The Configure Panels Dialog

You can display the Configure panels dialog by selecting View > Configure
panels... from the menu. The dialog contains a tab for each currently
displayed panel plus one tab marked
panel.

that you can use to create a new

To add a new box:
1.

Select the

2.

Select the required box type in the Type field.

3.

Fill in the remaining fields.

4.

Click on OK (to close the dialog) or Apply (to keep it open).

tab.

To modify an existing box, select the required tab, make your changes and
click on OK or Apply.
To delete an existing box, select the required tab and click on Remove panel.
The rest of the controls on the box configuration tabs vary according to the
type of the box, and are not described here.
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3 Using A Section Editor
A section editor is a tabbed window displayed in Content Studio's work area
that shows the content and properties of a section. Despite its name, it cannot
be used to edit anything. To open a section editor, right-click on a section in
the tree view at the top of the search panel (see section 2.2.2.1) or sections
pane (see section 2.2.2.2) and select Open Section.

All you can do with a section editor is preview the section's current section
page in a browser by clicking on the URL in the Properties tab at the top
of the window. The Active page link in the main part of the page is not of
interest to ordinary users of Content Studio.
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4 Using A Section Page Editor
A section page editor is a tabbed window displayed in Content Studio's work
area that you can use to edit a section page. You can open a section page
editor in the following ways:
• Double-click on a section in the tree view at the top of the search panel
(see section 2.2.2.1) or sections panel (see section 2.2.2.2). This will
open the section's active section page in an editor.
• Select a section in the tree view at the top of the search panel (see section
2.2.2.1) and then double click on one of the section pages displayed in the
section pages tab. This method allows you to edit section pages other than
the one which is currently active.

Sect ion page header

Sum m ary det ails

Opt ions and cont rols

Sect ion page cont ent s

A section page editor contains the following main areas:
• Section page header (at the top of the window)
• Section page contents (on the left)
• Summary details (on the right)
• Section page options and controls (at the bottom right)
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This description covers the basic section page editor functionality
delivered by Vizrt. Your Content Studio installation may include additions
that are not described here.

4.1

Section Page Header
At the top of the section page editor window are the following items:
• The section page and section name.
• The URL of the section. Clicking on this link opens the published section
page in your browser. Note that the page displayed in the browser is the
section's active section page, which may not be the page you are editing.
• A View button that you can use to switch between a Rich View and a
Plain View of the section page content (see section 4.2).

4.2

Section Page Content
The left hand side of the section page editor shows the structure of the section
page as a tree view. You can change the appearance of this tree view using
the View button in the header: it lets you switch the tree between a Rich
View and a Plain View.
Both options display the names of the areas defined by the section page's
grid layout, and show which content items have been placed in each area.
Neither view shows the exact layout of the section page, although the names
of the areas are usually descriptive ("top", "left column" and "right column"
are typical examples). The rich view shows more of each teaser's content (and
therefore uses more space) than the plain view, which only shows the title of
each teaser. You can expand and collapse parts of the tree by clicking on the
and

buttons on the left.

The instructions below describe how to edit the section page content. In order
to save any changes you make you must click on the Save Content button at
the bottom of the editor window.
Adding Content Items
To add a content item to the section page:
1.

Select the content item you want to add (in the search results list, one of
the section's inboxes/lists or your clipboard).

2.

Hold down the left mouse button and drag the content item to the
required area in the section page area. The color of the area's title bar
changes to indicate that it is now a drop target.

3.

Drop the content item by releasing the mouse button.

If the target area already contains content items, you can drop the new
content item between existing items - a short black line appears between the
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existing content items to show where the content item will be inserted if you
drop it.
Removing Content Items
To remove a content item from the section page:
1.
2.

Select the content item to remove.
Select Edit > Remove or press the Delete key.
Note that when you remove a content item from a section page, all you
are doing is removing the content item's summary from the section page.
You are not deleting the item, nor are you removing it from the section readers will still be able to find it via other links (should there be any) and
via search functions.

Moving Content Items
To move a content item to a new location on the section page:
1.
2.

3.

4.2.1

Select the content item you want to move.
Hold down the left mouse button and drag the content item to the
required area in the section page area. The color of the area's title bar
changes to indicate that it is now a drop target.
Drop the content item by releasing the mouse button.

Section Page Locking
As soon as you make any change to a section page, the section page is locked,
so that nobody else can work on it while you are making your changes. You
will see that a lock icon like this appears to the left of the title:

The whole section is now locked until you save or publish the changes you
have made. When you do so, you will see that the pencil disappears from
the icon, indicating that you are no longer editing the section page, and it is
therefore not locked:

You can release your lock on the section page by right-clicking on the lock
icon and selecting Release lock from the displayed menu. Note, however,
that doing this will revert all your unsaved changes. If you want to keep your
changes you should save them instead; this will also release the lock.
If you see this icon next to the section page title:
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it means that one of your colleagues is currently working on the section page
and it is therefore locked. You will not be able to make any changes. If you
hold your mouse pointer over the lock icon, the name of the person who
has locked the section page will be displayed. Once the person finishes their
editing, the lock icon will disappear and you can start editing.
Occasionally, situations can arise where locks are not released properly even though a person has finished editing a section page, their lock is not
released, meaning that you cannot get on with your work. This usually occurs
as a result of network problems. If this situation arises, you can get around it
by "stealing" the lock. To do this, right-click on the lock icon and select Steal
lock from the displayed menu.
You should only use the Steal lock function to escape from situations
where a lock has not been properly released. If you steal a lock from
somebody who is actually working on a section page, all their unsaved
changes to the page will be lost. If a section page you need to work on is
locked, first contact the person who has locked the page and agree with
them how to resolve the situation. It may simply be that they have moved
on to something else and forgotten to save their changes.
If somebody steals your lock while you are working on a section page you will
see the following message:

If this happens, there is nothing you can do to recover your lost changes.

4.2.2

Section Page Structure
Depending on how the section page's grid layout is defined, you may be
able to change the structure of the section page by inserting groups of subareas into areas on the section page, or removing existing groups. To find out
whether an area can be subdivided in this way, place the cursor somewhere
inside it and click the right mouse button. If either of the options Insert or
Group in the right-click menu is enabled, then the area can be subdivided.
If you select one of the enabled options, then a sub menu is displayed
containing the names of the groups you can use to subdivide the area.
Clicking on the Insert option, for example, might display a sub menu
containing the options Insert new Two-col group and Insert new Threecol group. Selecting Insert new Two-col group would insert a group called
Two-col into the area, which would own two areas (presumably) onto which
you could then drop content items. You can insert any number of groups
in this way, in any combination (although it may not be sensible to do so you need to have some idea of what the structures you add look like in the
publication, how much space is available and so on). In some cases, the areas
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in an inserted group may themselves offer the option of inserting further
groups, allowing you to build very complex page structures.
The Group option can only be selected when you right-click on existing
content items and/or groups in an area. Its sub menu contains options like
Group to Two-col and Group to Three-col. Selecting one of these options
inserts a group and moves all the selected items into the new group's first
area.
The Ungroup option is only enabled in an area that contains groups. Selecting
it removes all groups from the area and moves all their child content items to
the area.

4.3

Summary Details
Whenever you select one of the content items in the section page content
area, the content item's summary fields are displayed in the summary
details area on the right of the editor window, where you can edit them. The
particular fields that make up a summary vary from publication to publication.
Any changes you make to the summary fields here only affect this
section. The same article can appear with different summary headlines in
different sections.
In order to save any changes you make you must click on either the Save or
the Save & close button at the bottom of the editor window.

4.4

Options and Controls
At the bottom of the editor window is a Page options area and a set of
control buttons.
The Page options area contains a pull-down list and an Options button.
You can use the pull-down list to switch between different grid layouts. The
options available in this list are publication-specific. Some grid layouts may
have options. If you select a grid layout with options, then the Options button
is enabled; if you select a grid layout without options, then the Options
button is disabled.
Clicking on the Options button (if it is enabled) displays a dialog containing
the current layout's options. These options are part of the layout definition,
and are therefore publication-specific.
The following control buttons are displayed:
Preview
Displays a preview of the current state of the section page in your
browser (including all changes you have made, even ones you haven't
saved).

Copyright © 2008-2011 Vizrt

Page 35

Escenic Content Studio User Guide

Publish
Saves any changes you have made, and makes this section page the
active page (the one displayed in the publication). If you haven't made
any changes then the button is disabled.
Save
Saves any changes you have made. If you haven't made any changes
then the button is disabled.
Save & close
Saves any changes you have made and closes the section page editor.
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5 Using A Content Editor
A content editor is a tabbed window displayed in Content Studio's work area
that you can use to edit a content item. To open a content editor:
• Double-click on a content item or select one and press Enter. It doesn't
matter where you select the content item. You can select it in the search
results list in the search panel, in a section inbox/list, in your clipboard or in
a section page editor.
• Select File > New, and then select the type of content item you want to
create from the displayed sub menu. The options available in this sub menu
vary from publication to publication.
At t ribut e ribbons

Field select ion
Ruler
Field edit ors

Field panel t abs
Save/Preview/St at e cont rols

A content editor contains three main areas:
• Attribute ribbons (at the top of the window)
• Field tabs (the main part of the window)
• Save/preview/state controls (at the bottom of the window)
This description covers the basic content editor functionality delivered by
Vizrt. Your Content Studio installation may include additions that are not
described here.
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5.1

Attribute Ribbons
At the top of the editor window are a number of tabs, each of which displays
an attribute ribbon:
•
•
•
•

Field Options (see section 5.1.1)
Options (see section 5.1.2)
Tags (see section 5.1.3)
Properties (see section 5.1.4)

For content items that contain images you will also see an Image edit
controls ribbon. For information about this ribbon see chapter 7.

5.1.1

Field Options
This ribbon displays options that affect the currently selected field, so the
contents of the ribbon may change each time you select a different field in the
field tabs (see section 5.2).
Field options are mostly publication-specific and are therefore not described
here. In most publications, however, a formatting bar is displayed at the
bottom of the Field Options ribbon.

The formatting bar contains a set of formatting tools that allow you to format
the contents of fields in various ways. The kinds of formatting usually allowed
include:
•
•
•
•
•

Character formats such as bold and italic for emphasis
Inserting headings of various types (Heading 1, Heading 2 and so on)
Inserting bulleted and numbered lists
Inserting tables
Inserting images and media objects

The tools available in the formatting bar may vary from publication to
publication.
Not all fields can contain formatted text. The tools in the formatting bar are
only enabled if formatting is allowed in the currently selected field.

5.1.2

Options
This ribbon displays various options that affect the content item. The specific
options displayed can vary between publications and depend upon the type of
the content item. A Time Control option is always displayed however.
The Time Control option lets you set time controls on a content item: dates
and times on which the content item is to be activated and/or deactivated.
If you do this, then before it is activated and after it is deactivated, it is neither
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visible in the publication nor accessible to readers via searching, even if it has
been published.
The Time Control option has four settings:
None
No time controls are set.
Activation date only
Only an activation date/time is set. Once the activation date/time has
passed, the content item is permanently activated. Controls for setting
the activation date/time are displayed.
Expiry date only
Only an expiry date/time is set. The content item is activated until the
expiry date/time is reached. Controls for setting the expiry date/time are
displayed.
Activation and expiry dates
Both an activation date and an expiry date is set. The content item is
only activated between the specified dates/times. The specified expiry
date/time must be after the specified activation date/time. Controls
for setting both the activation date/time and the expiry date/time are
displayed.

5.1.3

Tags
This ribbons lists all the tags attached to the content item and lets you add
and remove tags. Tags are keywords that you can attach to content items.
They provide a simple and flexible way of categorizing and grouping content
items. You can use any word or sequence of words as a tag, and you can
assign any number of tags to a content item. You might, for example attach
the tags Barack Obama, Copenhagen, global warming and environment
to a news item about President Obama visiting the 2009 global warming
conference in Copenhagen. These tags let the story be automatically grouped
with other stories on related subjects, and can also be used by search engines.
To add or remove tags from a content item, click on the Tags link that
precedes the current list of tags. The tag editor panel is then displayed.
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Most of the pane is an existing tags area, used to list existing tags. Above
the existing tags area is a tag search/creation field and a row of buttons.
On the right is the Selected tags list, containing a list of the content item's
current tags.
Adding tags to content items
To add a tag to a content item either:
• Enter a tag in the tag search/creation field and click on the
• Click on the
area.

button, or

button to the right of one of the tags in the existing tags

The tag will immediately be added to the Selected tags list.
Removing tags from content items
To remove a tag from a content item, click on the
tag in the Selected tags list.

button to the left of the

Searching for tags
A useful way of ensuring you add all relevant tags to a content item is to
search for tags that have already been used in other content items.
To search for tags
• Enter a term in the search/creation field and press Enter/click on the
button, or
• Click on one of the tags in the existing tags area: it will then be copied into
the search/creation field and used as a search term
The content item then searches for the specified term, and lists all the tags
attached to the content items containing the term. The tags it finds are listed
in the existing tags area, allowing you to easily add them to your content
item. The tags are listed in order of popularity (how frequently they have been
used).
You can search for several terms at once by entering them in the search/
creation field separated by commas, and then clicking on the

button.

Viewing previous tag searches
You can view previous tag searches by clicking on the
towards your most recent search, click on the

button. To move back

button.

Closing the tag editor panel
To close the tag editor panel, simply click outside it.
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5.1.4

Properties
This ribbon displays various properties of the content item. None of the
displayed properties are editable. Among the displayed properties is the
content item's published URL, displayed as a clickable link. If the content item
is published, then clicking on this link will display the content item in your
browser.

5.2

Field Panel Tabs
A set of one or more tab cards contains the fields that make up the content
item. The fields that make up a content item vary widely from publication to
publication. A publication will also usually contain a number of different types
of content item, each of which has different fields.
The fields may all be displayed on a single tab card, or may be divided
among several. This also varies between publications (and within publications
according to content type). The following illustration shows a typical set of
field tabs (Main Content and Geotag). The field tabs in your publication
may, however, look quite different.

At least one of the fields in a content item will often be a large text field
(often called body) that is used to hold the main body of the content item.
Otherwise, fields can vary widely. Some allow any kind of text to be entered,
others are more restrictive: they have a maximum length, or only allow you to
enter numbers, or only allow numbers within a particular range. Other fields
may only allow you to select an option from a pull-down menu, or switch an
option on by checking a box. One special type of field (called a gallery field)
looks and behaves like a relation (see section 5.2.2), in that you can drop
items on to it. This kind of field is intended to simplify the editing of picture
gallery content items.
The content item's section bars (see section 5.2.1) are displayed at the
bottom of the first field tab card.
The content item's relations (see section 5.2.2) are displayed to the right of
the fields in the first field tab card, but only if relation display is switched on.
To switch relation display on and off, select View > Show Content Relations
or press Ctrl+F7.

5.2.1

Section Bars
Section bars show the sections a content item belongs to, and allow you to
control various aspects of its section membership. One bar is displayed for
each section in which the content item appears, at the bottom of the first
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field tab card. The bars are grouped together by a vertically aligned bar at the
left containing the name of the publication the sections belong to.

If the content item has not yet been added to any sections, then a drop zone
for sections is displayed at the bottom of the tab card:

A section bar represents one of the sections in which the content item
appears.

The name of the section is displayed at the left hand end of the bar. At the
right hand end of the bar are:
• The inbox/list menu button
• The home section button (
• The remove button (

)

)

You can use the section bars for a variety of purposes, described below.
To add the content item to a section:
1. Make sure the section bars or section bar drop zone is visible
2.

Display the Sections panel in the navigation area.

3.

Select the required section from the section tree in the Sections
panel.

4.

Either:
• Drag it into the content editor and drop it in the drop zone or on
top of an existing section bar, or
• Press Alt + right.

A new section bar representing the section appears.
To remove the content item from a section:
Click on the
button of the appropriate section bar. The content item is
removed from the section and the section bar disappears.
You cannot remove a content item from its home section. If the
button on a section bar is selected, then the

Page 42

button is always

Copyright © 2008-2011 Vizrt

Escenic Content Studio User Guide

disabled. (This is, however, not true for local home sections, see
section 5.2.1.1).
To change a content item's home section:
Click on the
to.

button of the section you want the content item to belong

To place a content item in a section inbox:
1. Click on the inbox/list of the appropriate section bar.
2.

Select the inbox you want from the displayed list. Note that a
content item can only belong to one of a section's inboxes: if it was
in a different inbox, then it is moved to the one you select.

To add a content item to a section list:
1. Click on the inbox/list menu of the appropriate section bar.
2.

5.2.1.1

Select the list you want from the displayed list. The content item
is added to the end of the selected list. If you want it in a different
position, then you will need to open the list and edit it (see chapter
6).

Cross-publishing and Local Home Sections
The Escenic Content Engine can be used to manage a family of related
publications, and may be set up to allow cross-publishing. A cross-published
content item is a content item that belongs to one publication (its home
publication), but appears in other publications. If a content item is crosspublished, then the section bar area will contain several blocks of section bars,
one for each publication in which the item appears, with the home publication
section block at the top:

Foreign publication section blocks behave slightly differently to the home
publication's section block. The main difference is that, while the home
publication section block must contain a home section, foreign publication
section blocks are not required to. However, if a content item appears in more
than one section of a foreign publication, you are recommended to ensure that
one of them is the local home section. The content item will then take its
published appearance from this section.
If you do not pick a local home section, then it is uncertain which section will
be used to determine the appearance of the cross-published content item.
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You can always see section blocks and bars for all the publications and
sections in which a content item appears, but you can only modify them if
you have sufficient access rights.

5.2.2

Relations
A content item can have related content items. Related items can be used for
many different purposes. They can, for example, be:
• Other articles on the same subject, presented as links in the published
article
• Images used in the article
• Media objects used in the article
• Profiles of persons associated with the article (authors, editors etc.)
• Links to external resources used in the article
A content item's type determines what kinds of related content items it may
have, and how they are used. The related content items are referred to as the
content item's relations.
A content item's relations are displayed on the right of the first field tab card.
They can, however, be hidden. To hide/show the relations, select View >
Show Content Relations or press Ctrl+F7.
The organization of the relations area varies between publications and
content types. It is usually divided up into several groups, each with a heading
describing the group's purpose. For example:
• A group with the heading "More on this issue" might be intended to contain
other articles on the same subject, which are then presented as a list of
links in the published article.
• A group called "Front page image" might be intended to contain the image
that will be used if the article is included in the publication's top level
section page.
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Each group either already contains one or more related content items or else
contains a drop zone for relations.

In order to use relations successfully, you need to know their purpose in your
publication.
To add a relation to a content item:
1. Make sure the content item's relations/relation drop zones are
visible.
2.

Find the content item you want to add as a relation (in the Search
panel's results list, an inbox/list or on your clipboard).

3.

Either:
• Drag it to the required relation group and drop it, or
• Press Alt + right and pick the required relation type from the
displayed pop-up dialog

To remove a relation from a content item:
1. Select the relation you want to remove.
2.

Select Edit > Remove or press Delete.

You can control how much of the related content items are displayed in
the Relations area with the Views button, displayed at the top of the area.
Clicking on this button switches between the following views:
All fields
All relation fields are displayed.
Short
Only the title is displayed.
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5.2.3

Field Locking
As soon as you make any change to a the contents of a field or relation, it is
locked, so that nobody else can work on it while you are making your changes.
You will see that a
appears next to the field/relation title. The field is now
locked until you save your changes. A similar icon will appear in every field/
relation you modify. When you save the content item, you will see that all
these icons disappear, indicating that you are no longer editing any of the
content item's fields or relations, and they are therefore not locked.
You can release your lock on on a field or relation by right-clicking on the
icon and selecting Release lock from the displayed menu. Note, however,
that doing this will revert the changes you made to the field. If you want to
keep your changes you should save them instead; this will also release the
lock.
If you see a icon next to a field or relation title, it means that one of your
colleagues is currently working it, and it is therefore locked. You will not be
able to make any changes. If you hold your mouse pointer over the lock icon,
the name of the person who has locked the field will be displayed. Once the
person finishes their editing, the lock icon will disappear and you can start
editing.
Occasionally, situations can arise where locks are not released properly even though a person has finished editing a field, their lock is not released,
meaning that you cannot get on with your work. This usually occurs as a
result of network problems. If this situation arises, you can get around it by
"stealing" the lock. To do this, right-click on the lock icon and select Steal
lock from the displayed menu.
You should only use the Steal lock function to escape from situations
where a lock has not been properly released. Stealing a lock from
somebody who is actually working on a field or relation is very disruptive.
If a field you need to work on is locked, first contact the person who has
locked it and agree with them how to resolve the situation. It may simply
be that they have moved on to something else and forgotten to save their
changes.
If somebody steals your lock while you are working on a field or relation you
will see a dialog something like this:

If this happens and you want to save the changes you have made, copy the
content of the field from the dialog, paste it into another editor and save it
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there. When you recover access to the field, you can copy your saved content
back into the field. Note, however, that the user who stole your lock has
presumably also made changes to the field. If you simply paste your content
back into the field it will overwrite his/her changes. You may therefore need to
find out what changes the other user made and carefully merge the two sets
of changes.

5.3

Save/Preview/State Controls
At the bottom of the editor window are the following controls:
Preview
Displays the content item in your browser, showing any changes you
have made, even if you have not saved them yet.
Save
Saves any changes you have made. If you haven't made any changes
then the button is disabled.
Save & close
Saves any changes you have made and closes the content editor editor.
State
Lets you change the state of the content item. The following states can
be selected:
•
•
•
•

Draft
Approved
Submitted
Published

A content item page that is in any of the first three states is not visible in
the web publication even if it has been added to an active section page
and cannot be found by searching; a content item in the Published
state is visible and can at least be found by searching. The first three
states can be used to represent various stages in your organization's
work flow, but have no effect on how a content item is handled by the
Content Engine or Content Studio.

5.4

Editing XHTML Text
Some of the fields in a content item may contain formatted text. A typical
textual content item has one such field (often called body) that holds the main
content. When you put the cursor in a field that contains formatted text, the
formatting bar displayed at the bottom of the Field Options tab (see section
5.1.1) is enabled:
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You can then use the buttons in this bar to format the text you enter. The tools
available in the formatting bar may vary from publication to publication.
Internally, the formatted text is stored as XHTML. You can, if you wish, view
the source XHTML and/or edit it. To do so:
1.

Right-click somewhere in the formatted field.

2.

Select Edit Source from the displayed menu. The source XHTML is then
displayed. An OK and a Cancel button is also displayed at the bottom of
the field.

3.

Examine/edit the displayed XHTML.

4.

To save your changes, click on OK, or click on Cancel to cancel any
changes you may have made.

You can use this function to:
• Insert or modify XHTML code in ways that the formatting bar does not allow.
• Paste in blocks of XHTML code copied from other programs or web sites.
It is particularly useful for pasting in predefined video links copied from web
sites such as YouTube, Flash animations and so on.
You should be careful using this function unless you are comfortable
editing XHTML code. Error messages are displayed at the top of the field
if the content is invalid, which provides some guidance. When you save
your edits, any mistakes you make will be corrected to ensure that the
field contains valid XHTML, but the corrections may give unexpected
results.
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6 Using A List Editor
A list editor is a tabbed window displayed in Content Studio's work area that
you can use to edit a list. To open a list editor:
1.

Open the Sections panel.

2.

Select a section.

3.

Click on the Lists tab.

4.

Either:
• Select a list and the select File > Open Selected to open it, or
• Right-click in the Lists tab card and select Create New List...
from the displayed menu; then enter a name for your new list in the
displayed dialog.

A list editor is very simple: all you can do with it is:
• Add content items to the list and remove them.
• Reorder the list.
To add a content item to the list:
1. Select the content item you want to add (in the search results list,
one of the section's inboxes/ other lists or your clipboard).
2.

Hold down the left mouse button and drag the content item to the
required position in the list.

3.

Drop the content item by releasing the mouse button.

To remove a content item from the list:
1. Select the content item you want to remove.
2.

Select Edit > Remove or press Delete.

To reorder the list:
Select one or more content items in the list, drag them to a new position
and drop them.
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You can use the Views button in the top right corner of the editor to change
the layout of the list in the editor. There are three layouts available:
Detail
The default view.
List
A simplified view with no images.
Thumbnail
Image thumbnails only.
The Views button only affects how you see the list in the editor. It has no real
effect on the list or its contents.
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7 Editing Images
If you open an image content item, you will notice that the content editor in
which it is displayed looks quite different from a "standard" text-only content
editor. The main differences fall into three categories:
The field containing the image
This field is different in several ways from a standard text-based field:
• It always comes first, before all other fields.
• It has no label.
• Since it contains the image, it is usually quite a bit larger than most
other fields.
• It occupies the full width of the content editor tab - any relation drop
zones in the content item are shown below the image field alongside
any other fields in the content item.
• There is a ribbon of display controls below the image.
For further information about image fields, see section 7.1.
The Image edit controls ribbon
An image content editor always has an extra ribbon at the top of the
editor, called Image edit controls. This ribbon, as its name suggests,
contains various controls that you can use to edit the image.
For further information about the image edit controls, see section 7.2.
An "image versions" field panel
Depending on how your publication is structured, image content
items may have a field panel called something like "versions", "image
versions" or "alternatives" that contains alternative, cropped versions of
the main image. If your image cntent item has such a panel, you can use
it to modify the alternative images shown there.
For further information about image version field panels, see section
7.3.
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7.1

Using The Display Controls

Im age field

Display cont rols

The above illustration shows an image field, with a ribbon of display controls
at the bottom. You can use these controls modify how the image is displayed
in Content Studio or to examine it more closely in an external editor, but
nothing you do with them will affect the stored image in any way. The display
controls are:
Open in external editor
Downloads the image to your computer and opens it in an external
image editor. By default this will be Paint on a Windows PC or Preview
on a Mac, but your computer may be set up to use other image editors
by default. You can do whatever you like to the image in the external
editor, but any changes you make will have no effect on the original
image in the field. If you save any changes, they will be saved locally in
a file on your computer. If you want to edit the image in the field, you
must use the image edit controls (see section 7.2).
100%
Resizes the image to it's proper size.
Fit
Resizes the image to fit the available space in the field.
Zoom slider
Lets you resize the image interactively by moving the slider along the
scale.
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7.2

Using The Edit Controls
You can edit an image using the edit controls in the Image edit controls
ribbon displayed above the field:

Im age edit cont rols

Crop m ask

Resize handle

There are three groups of editing controls which you can use for rotation,
cropping and enhancement. Any changes you make using these functions
are not finally applied to the image in the Escenic database until you save
the content item by clicking on the Save button at the bottom of the content
editor tab.
If the Image dimensions in the Image edit controls tab are
displayed in red and followed by the warning (too large), you will
not be able to edit the displayed image, as it is too large to be loaded
into memory. Should this happen, report the problem to your system
administrator. The problem can be fixed by modifying a setting in the
StudioConfig.properties file on the Content Engine host. For details
see Escenic Content Engine Server Administration Guide, section
14.3.

7.2.1

Rotation
There are two rotation controls:
Rotate left
Rotates the image 90° counter-clockwise.
Rotate right
Rotates the image 90° clockwise.
It is not possible to rotate the image in anything other than 90° increments.
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7.2.2

Cropping
To crop the image:
1.

Select a crop mask from the Select a crop mask list.

2.

If you want to resize or reshape the crop mask that is superimposed on
the image, you can do so by dragging the yellow handles displayed at the
corners of the mask. If you want to move it, you can do so by placing the
mouse pointer inside the mask and dragging.

3.

When you are satisfied with the crop location, click on Crop to crop the
image. Alternatively, click on Cancel to cancel the operation.

Most of the crop masks in the Select a crop mask list have a fixed aspect
ratio: that is, you can change the size of the crop mask by dragging on its
corner handles, but you cannot change its shape. The Free crop mask,
however, can be reshaped as well as resized. The sides of this mask are
draggable as well as the corners.

7.2.3

Image Enhancement
There are three image enhancement functions: Sharpness, Brightness
and Contrast. For each of these functions there is an Increase button and
a Decrease button. Clicking one one of the Increase buttons increases the
sharpness, brightness or contrast of the image by a small increment. Clicking
one one of the Decrease buttons decreases the sharpness, brightness or
contrast of the image by a small increment. You can increase the effect of any
of these functions by clicking a button repeatedly.

7.3

Alternative Image Versions
Most publications are set up to support multiple versions of images in different
shapes and sizes for use in different contexts. You might want, for example,
a large version for displaying in articles, a small version for displaying in
headline teasers and a thumbnail version for displaying in other teasers; or
landscape and portrait versions for displaying in wide column and narrow
column layouts. Each version has a predefined width, height or width and
height, specified in pixels. A "landscape" version might be defined as 500
pixels wide and 400 pixels high, for example, a "portrait" version defined as
400 pixels wide and 500 pixels high, and a "narrow" version defined as 300
pixels wide but with no fixed height.
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Usually these alternative versions will be displayed on a separate tab in the
content editor, for example:

Crop m ask

Resize handle

The alternative images tab contains one copy of the image for each version
that has been defined. Superimposed over each image is a crop mask.
If an alternative version defines both width and height, then its crop mask has
a fixed aspect ratio, which means that you can resize it and move it, but not
change its shape. If it only defines one dimension (height or width), then you
can also change the shape of the crop mask.
The crop mask is initially set to include as much of the base image as possible,
and is centered.
If you click inside one of the crop masks then it is highlighted, and yellow
handles appear at each corner. You can then:
• Resize/reshape the crop mask by dragging on the handles
• Move the crop mask by placing the mouse pointer inside it and dragging
In this way you can select which part of an image is to appear in each of the
versions.
When you change the size of a fixed-aspect ratio crop mask, you do not
affect the size of the image version in the publication, you simply select
what is to appear in it. Whatever you select is scaled up or down to fill the
image version's predefined area. Similarly, whatever selection you make
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for a fixed width/height version is scaled up or down to fit the predefined
width or height.
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8 Keyboard Shortcuts
Content Studio supports a number of keyboard shortcuts for experienced
users. These shortcuts are listed below. In some cases, the meaning of a
shortcut is changes slightly with the current context (the Delete key, for
example). Similarly, some shortcuts only work in certain contexts: the Ctrl+B
shortcut, for example, only works when editing text in an HTML field.
You can display a list of shortcuts at any time by selecting View > View
keyboard shortcuts....
Note that on Macs, some of the shortcuts may clash with OS X shortcuts.
If this is the case, then the operating system wins, and the shortcut
executes the OS X function, not the function listed below. For example, if
you have enabled the OS X Spaces feature and use the default shortcuts,
then the shortcuts Command+1 to Command+n will not affect Content Studio
at all, but will switch screens as defined in your Spaces configuration.
Function

Windows

Mac

Open selected item(s)

Enter

Close active editor
Delete
Delete text in active editor field
Remove item(s) from list/inbox/
clipboard
Save
Reload search results
Reset search parameters to their
default setting
Undo
Redo
Cut
Copy
Paste
Rename
Resize section editor
Select all text in active editor field
Select all items in list/inbox/clipboard
Show/hide all panels
Log out and exit
Exit
Show/hide relations
Show help
Show "about" information
Show search panel

Ctrl+F4
Ctrl+D
Delete

Command+O (letter
O)
Command+W
Command+D
Delete

Ctrl+S
F5
Ctrl+Home

Command+S
Command+R
Command+Home

Ctrl+Z
Ctrl+Y
Ctrl+X
Ctrl+C
Ctrl+V
F2
Ctrl+F8
Ctrl+A

Command+Z
Shift+Command+Z
Command+X
Command+C
Command+V
Enter or Return
Command+8
Command+A

Ctrl+F11
Ctrl+Shift+Q
Alt-F4
Ctrl+F7
F1
F8
Ctrl+F1

Command+9
Shift+Command+Q
Command+Q
Command+6
F1
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Function

Windows

Mac

Upload local files

Ctrl+O (letter O)

Bold
Italic
Underline
Preview
Show/hide boxes
Open panel configuration dialog

Ctrl+B
Ctrl+I
Ctrl+U
Ctrl+P
Ctrl+F6
Ctrl+F12

Shift+Command+O
(letter O)
Command+B
Command+I
Command+U
Command+P
Command+5
Command+0 (digit
0)
Shift+Command+V
Shift+Command+P

Edit Source
Ctrl+Shift+V
Publish current content item and save Ctrl+Shift+P
(if possible)
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